Dentrix G-4 and Windows

by Larry Emmott on March 24, 2009

in Software

I just discovered that Dentrix is not compatible with 64 bit versions of Windows. So if you are adding a computer to a Dentrix network get the 32 bit version of Vista Business or if possible you may want to stay with XP-Pro.

by: at .

Share

Comments on this entry are closed.

Previous post:

Next post: